The most important part about any code is readability.
BSL, ML, SL, BR, vInc, etc. might mean something to you, but it's not clear what it means by just looking at the names.
var BSL = 0 // Bonus round selector
This would be much clearer as
var bonusRoundSelector = 0
You have done the same thing for a lot of your variables. In some cases ...