The method name load_Directory_Files is a bit odd. To follow general Java naming conventions, it would be something like loadDirectoryFiles. This is called camel case.
You can use a FileFilter to accept or discard files for the
listFiles call, no need to do it yourself: