Episode #125 of the Stack Overflow podcast is here. We talk Tilde Club and mechanical keyboards. Listen now
6

First of all, it is great that you wrote this algorithm and that it works. I'll try to collect all remarks that I would normally note while reviewing this code having the formal task. Package naming According to Java style guides you are not allowed to name a package using capitals letters. The correct package name will be foo. However, foo is an extremely ...


2

There are a few holes in the specification for which you have implemented code. E.g. the color outside the charts. The picture has white color but you used black. If you didn't ask clarification for those, that might have a negative effect on your evaluation. On the other hand, the specification says that the view can have "maximum of two charts" meaning ...


2

eEmbosserType Don't use Hungarian Notation in C#. A better name would be EmbosserType or EmbosserKind. IEmbosser This is a public interface, so I would expect that consumers could make their own implementations. If this is allowed, consumers are hampered by EmbosserType because this enum is under your control. Consider using an external key like string if ...


1

The simplest solution would be to drop the totalBalance field and simply have getTotalBalance calculate the value: public BigDecimal getTotalBalance() { return this.principalDue.subtract(this.penaltyPaid) .add(this.interestDue).subtract(this.interestPaid) .add(this.feeDue).subtract(this.feePaid) .add(this.penaltyDue).subtract(...


Only top voted, non community-wiki answers of a minimum length are eligible