1

I agree with your summation that it is clumsy. I see you like to stringly type objects, such as GetTimeOfDayFromDateTime. It would be neater to just get the time of day as a TimeSpan. Also, you may have several overloads accepting different input arguments, so you don't need to include the FromDateTime in the name. public static TimeSpan GetTimeOfDay(...


Only top voted, non community-wiki answers of a minimum length are eligible