I would like to refactor this block, it looks clunky:
# refactor me
receive_payment_on = false
config[:sections].each do |section|
if section[:applicants]
section[:applicants][:sections].each do |app_sec|
if app_sec[:employment] && app_sec[:employment][:receive_payment_on]
receive_payment_on = true
end
end
end
end