Great tips from the other answer, here are just some more bits and bobs.
Use the library capabilities to their fullest
char1 = a
new_list = data
char2 = random.choice(data)
This, in addition to the uncommon indentation sticks out to me. Why are we removing, why are we adding, why are we redefining? ...
I'm not going to go too heavily into refactoring the whole thing.
Some basic readability things:
return_values = compare(options, options, score)
score = return_values
lost = return_values
It would be much clearer if you did:
lost, score = compare(options, options, score)
You have indented things with two spaces, which is odd, normally ...