New answers tagged

0

Speaking strictly about the code and not the approach in general. Use array destructuring to get nicer, more readable variables: [$whole, $decimal] = explode('.', $rating); Some syntactic sugar to replace if/else: $rate_emp = ($decimal ? 4 : 5) - $whole; Loops can be replaced by str_repeat(). Optionally, you can check if repeat count is less than 1 and ...


1

Disclaimer This is my response based on the following information: At the start, all countries with basic details shall be listed. A user can type some string and the countries displayed will be reduced to only those matching the filter. At anytime, before or after searching, a country "card" can be clicked, forcing the page to update with more ...


4

UX Overall, fine. Good use of labels. Getting an invalid input error off the bat is a bit jarring. Consider formatting the result to a readable number of decimal places (say, 2) unless you have good reason to be more precise. Code style In general, try to stick to conventions and be consistent. JS JS uses camelCase rather than snake_case (p_test_given_pos). ...


Top 50 recent answers are included