You could add a "while" loop instead of an "if" statement. This will allow the user to keep trying until it is correct, and is very pythonic. Also if you want to be really clean review [PEP8 "function and variable names"](https://www.python.org/dev/peps/pep-0008/#function-and-variable-names). You'll want your variables lower case, with underscores "_". [Python Zen](https://www.python.org/dev/peps/pep-0020/) says "Explicit is better than implicit." Therefore I would change around your variable names to be more readable. For example: import random max_num = 10 random_num = random(0, max_num) guess = input() while not guess == random_num: print("Sorry, wrong number.") guess = input() print("You got it!")