I don't have the time now to do a full breakdown, but the first thing that comes to mind when seeing your code is changing this
if (sheet.GetRow(i).Cells[col].ToString() == "ATM") ATM = col;
else if (sheet.GetRow(i).Cells[col].ToString() == "Card-AMEX") AMEX = col;
else if (sheet.GetRow(i).Cells[col].ToString() == "Card-MASTER") MASTER = col;
else if (sheet.GetRow(i).Cells[col].ToString() == "Card-VISA") VISA = col;
else if (sheet.GetRow(i).Cells[col].ToString() == "Cash") CASH = col;
To the following (it might seem like more lines of code, but its way more readable and doesn't repeat sheet.GetRow(i).Cells[col].ToString()
5 times.
switch(sheet.GetRow(i).Cells[col].ToString())
{
case "ATM": ATM = col; break;
case "Card-AMEX": AMEX = col; break;
case "Card-MASTER": MASTER = col; break;
case "Card-VISA": VISA = col; break;
case "Cash": CASH = col; break;
}