I would appreciate some help with camera movement and zoom. Is there any easier way with cleaner code, or simply how can I improve it?

  • Window size: 800x600
  • Image size: 1200x900

This is my code so far (you can move with the camera only around the image and use zoom):

package game.engine.gui;

import game.engine.Engine;
import java.awt.Graphics2D;
import java.awt.Point;
import java.awt.Rectangle;
import java.awt.event.MouseEvent;
import java.awt.event.MouseWheelEvent;
import java.math.BigDecimal;

public class Camera {

public Point mouseLocation;
public boolean drag = false;
public boolean isEnabled = true;
public Rectangle view;
public int offsetX = 0;
public int maxOffsetX = 200;
public int maxOffsetXZoom = 200;
public int offsetY = 0;
public int maxOffsetY = 150;
public int maxOffsetYZoom = 150;
public float zoom = 1;
public float maxZoom = 1.2F;
public float minZoom = 0.7F;

public Camera() {
    view = new Rectangle(0,0,Engine.window.getWidth(),Engine.window.getHeight());

public void draw(Graphics2D g)

public void update()

public void mousePressed(MouseEvent e)
        mouseLocation = e.getPoint();
        drag = true;

public void mouseReleased(MouseEvent e)
    drag = false;

public void mouseMoved(MouseEvent e)

public void mouseDragged(MouseEvent e)
        int newoffsetX = offsetX - (mouseLocation.x - e.getX());
        int newoffsetY = offsetY -  (mouseLocation.y - e.getY());
        if(newoffsetX > maxOffsetXZoom) offsetX = maxOffsetXZoom;
        else if(newoffsetX  < -maxOffsetXZoom + (maxOffsetX-maxOffsetXZoom) * 4) offsetX = -maxOffsetXZoom + (maxOffsetX-maxOffsetXZoom) * 4;
        else offsetX = newoffsetX;
        if(newoffsetY  > maxOffsetYZoom) offsetY = maxOffsetYZoom;
        else if(newoffsetY < -maxOffsetYZoom - 25 + (maxOffsetY-maxOffsetYZoom) * 4) offsetY = -maxOffsetYZoom - 25 + (maxOffsetY-maxOffsetYZoom) * 4;
        else offsetY = newoffsetY;
        mouseLocation = e.getPoint();

public void mouseScrolled(MouseWheelEvent e)
    if (e.getWheelRotation() < 0) {
        if(zoom<maxZoom) zoom += 0.05F;
    } else {
        if(zoom>minZoom) zoom -= 0.05F;
    zoom = round(zoom, 2);
    maxOffsetXZoom = (int) (maxOffsetX * zoom);
    maxOffsetYZoom = (int) (maxOffsetY * zoom);
    if(offsetX > maxOffsetXZoom) offsetX = maxOffsetXZoom;
    else if(offsetX  < -maxOffsetXZoom + (maxOffsetX-maxOffsetXZoom) * 4) offsetX = -maxOffsetXZoom + (maxOffsetX-maxOffsetXZoom) * 4;
    if(offsetY  > maxOffsetYZoom) offsetY = maxOffsetYZoom;
    else if(offsetY < -maxOffsetYZoom - 25 + (maxOffsetY-maxOffsetYZoom) * 4) offsetY = -maxOffsetYZoom - 25 + (maxOffsetY-maxOffsetYZoom) * 4;

public float round(float d, int decimalPlace) {
    BigDecimal bd = new BigDecimal(Float.toString(d));
    bd = bd.setScale(decimalPlace, BigDecimal.ROUND_HALF_UP);
    return bd.floatValue();

It works, but I think it's a huge mess and also if the image size was different it would require a lot of changes. I am using my own engine.

  • \$\begingroup\$ Please do not update the code in your question to incorporate feedback from answers, doing so goes against the Question + Answer style of Code Review. This is not a forum where you should keep the most updated version in your question. Please see what you may and may not do after receiving answers. If you have updated code you want to have reviewed, please post a new question. And yes, I'm aware of the age of the question. \$\endgroup\$
    – Mast
    Nov 25, 2022 at 18:19

1 Answer 1


I'm going to assume your indentation got messed up on posting, but just in case, you should indent all of the code inside of the Camera class an additional time.

First off, I like that you used constants at the top of your code! To ensure that they look and act like constants, you should make them private, static, final, and named in UPPERCASE_FORMAT. Furthermore, I would recommend separating your constants from your class variables (such as mouseLocation and offsetX).

I'm not entirely sure how your functions are being called. It looks like you are implementing MouseMotionListener, so I would definitely add that to your class declaration.

If that is true, then I don't see the purpose of the drag variable. The mouseDragged function is only going to get called if the mouse is actually being dragged, so assigning a boolean when the mouse is pressed and released appears redundant.

Also, I'd recommend considering whether you want to use BigDecimal. If round needs to be fast, then you don't want to use BigDecimal at all. There are other techniques for rounding to the nth digit that can be found here

  • \$\begingroup\$ Thank you, I changed the constants, removed the useless drag boolean and also removed void round and left the float unrounded (I rounded it only because it looked better like 1.05 than 1.050000001, but it will not be visible outside of debug anyways). Functions like mouseDragged are called by my engine which has various listeners. \$\endgroup\$
    – Ladas125
    Jul 15, 2015 at 17:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.