I was going to go through your code and rewrite it but some of the names are very ambiguous so I do not want to in case I break something.
Also a few of these points are duplicated from @vmariano.
Focus on using names that make sense. v and c do not make much sense to me at all. They do not mean anything to me. Perhaps they are part of a chemical formula, but I am not a chemist and a vast majority of programmers also will not be. Imagine that the code you are writing is being shown to someone who only knows how to program in the language you are programming in, and nothing else. The code still has to make sense to them.
You should avoid the liberal use of this. It can be rebound function call to function call very easily. Whilst some this is OK, and even necessary, it is better to at least keep it consistent. To give you an idea, the this in your Stream constructor could refer to a different this to the this in the Stream.Show method.
In general, PascalCase for constructors - camelCase for everything else.
function Stream is fine and lets you use the function before the function itself is declared.. this is known as a function declaration. However this can make the code harder to read because you place all of the functions at the bottom. Consider using a combination between function express and declaration - var Stream = function Stream(). You will have to place this before your working code but it is a lot cleaner to read and you still maintain the name of the function in console.log or stacktraces.
Better yet, your code right now does a lot. How about you move each constructor into it's own file and require them (or load them in the right order/use browserify/requirejs if you're writing this for the browser)?
Avoid assigning null to values by default, it will cause your code to break. Instead, assign sensible defaults or nothing at all. Values that are not assigned have the special value undefined.
Instead of using new Stream() in your functions, consider passing in a stream into the constructor itself; this will decouple your code.
Your Math.abs call at the end of the code is confusing. Keep it on one line. IF the line is too long, then change the names of variables to make them shorter.