I want to create an extended disable/enable function in jQuery. This is working, but is this the best solution? Is each loop necessary?

 $.fn.ariaDisabled = function (isDisabled) {
        /// <summary>
        ///     Sets the disabled state.
        /// </summary>
        return this.each(function () {

            var $item = $(this);

            if (isDisabled === true) {
                    .attr('disabled', 'disabled')
                    .attr('aria-disabled', 'true')
            else {
  • \$\begingroup\$ If the function is called ariaDisabled then it should only change the [aria-disabled] attribute. \$\endgroup\$
    – zzzzBov
    Commented Jan 12, 2015 at 15:18

1 Answer 1


Overall it looks quite nice. Just a few points:

  • The parameter name is asking a question about the element, not making a statement of what to do. I would rename it to disable which enables the caller to better signify their intent.
  • In the same vein, I would also rename the function to ariaDisable as it performs an action as opposed to asking a question


Per m90's comment the loop is per jQuery plugin conventions as noted here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.