The question is: Why do you want to change it?
I bet you can get a shorter form with some use of xor, and, or etc. functions but I believe it's not worth it. For example:
public bool IsAllDayZero
(Today | Days1_2 | Days3_6| Days7_10 | Days11_15 |
Days16_30 | Days31_45 | Days46_60 | Days60Plus) == 0;
It's indeed shorter but no way that it's more clear for some other person about what this code tries to achieve.
Or you can get a faster version that will revert the conditions and then execute only few conditions without a need to check them all but again I doubt that clarity of the code will worth such a changes.
However your current implementation is clear, complete and does exactly what it has to do without some extra noise and I just recommend not to change it.