3
\$\begingroup\$

EDIT: I turned down the brightness on my monitor using the graphics options for the video card. This solved the issue. How this setting changed is a mystery...

I am leaving this up because googling it leads down some difficult and unhelpful paths.

ORIGINAL:

Google maps has become washed out. I cannot see roads. I have made a hack work around that dims the page to make the roads contrast with the map

See https://www.youtube.com/watch?v=MAPfjlwMyB4 for example of issue I am having.

Now, I made a snippet inside the developer console in chrome to "fix" this, but I am certain there are better ways to do it.

Here is the snippet:

var style = document.createElement('style');
style.type = 'text/css';
style.innerHTML = '.mapsTactileClientSettingsMain__widget-settings-offscreen .widget-settings-shim { width: 100%; height: 100%; opacity: 0.3; pointer-events: none; }';
document.getElementsByTagName('head')[0].appendChild(style);

This only works AFTER I have accessed the hamburger menu at least once. If I run the script before then, it has no effect.

The script simply uses the same overlay that google uses to dim the map while the menu is open. But it changes it to be "on" even when you aren't accessing the menu. It also disables mouse interaction with the overlay so the user can interact with the map.

I am looking for improvements or entirely different fixes that are better.

Thank you.

\$\endgroup\$

1 Answer 1

1
\$\begingroup\$

I am looking for ... entirely different fixes that are better.

Turn the brightness down using your operating system, graphics card software, or monitor.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.