Link: https://www.hackerrank.com/contests/hackerrank-all-womens-codesprint-2019/challenges/name-the-product/


You are contesting to name a new product in your company given the following conditions:

You are given an array of \$n\$ different names, \$names\$, where \$names_i\$ denotes the \$i^{th}\$ name and all the names are of length \$5\$. The distance between any two names is the number of positions in which the characters in these names differ. For example, "bubby" and "bunny" differ in two positions.

You have to choose a name such that the sum of differences of all names in \$names\$ with the chosen name is maximal. In order to win the contest, give the new product this chosen name.

Note: If there are many such names chose the lexicographically largest one.

Take for example, names = ["bubby", "bunny", "berry"], with length \$n = 3\$. Then, the name that you should choose is "zzzzz" as this name has no common character with any name in the names list and is also lexicographically the largest.

Function Description

Complete the productName function in the editor below. It should return the lexigraphically largest string of length whose sum of differences with all the names is maximal.

productName has the following parameter(s):

names: array of \$n\$ names

Input Format

  • The first line contains an integer, \$n\$, denoting the number of elements in \$names\$.
  • Each line \$i\$ of the \$n\$ subsequent lines (where \$0 \le i \le n\$) contains a string describing \$names_i\$.


  • \$1 \le n \le 10^5\$
  • All characters in the names are lowercase English alphabets.
  • Each name is of length \$5\$.

Output Format

  • The output should contain the lexigraphically largest string of length whose sum of differences with all the names is maximal.

Sample Input 0


Sample Output 0


Explanation 0

  • Difference between \$names_0\$, bubby, and zzzzz is \$5\$.
  • Difference between \$names_1\$, bunny, and zzzzz is \$5\$.
  • Difference between \$names_2\$, berry, and zzzzz is \$5\$. So, total difference is 15, which is maximal.

Sample Input 1


Sample Output 1


Explanation 1

  • Difference between \$names_0\$, ready, and yzzzz is \$5\$.
  • Difference between \$names_1\$, stedy, and yzzzz is \$5\$.
  • Difference between \$names_2\$, zebra, and yzzzz is \$5\$. So, total differce is 15, which is maximal.

I would strip the extraneous parts from my solution:

import math, os, random, re, sys
from collections import defaultdict as dd, Counter as count

alphabet = "abcdefghijklmnopqrstuvwxyz"
def productName(names):
    charmap = [dd(lambda: 0, count(name[i] for name in names)) for i in range(5)]
    return "".join(max(alphabet, key=lambda x: (-charmap[i][x], x)) for i in range(5))   

I'm concerned with adhering to best practices and maximising performance.

  • \$\begingroup\$ Meta comment, writing up the question took me much more time than actually solving the question due to the copious amounts of formatting involved. I would likely submit more questions from this particular codesprint, would leaving out the problem description and merely dropping the link be acceptable? \$\endgroup\$ Commented Mar 18, 2019 at 10:38
  • 12
    \$\begingroup\$ Absolutely not. \$\endgroup\$
    – Mast
    Commented Mar 18, 2019 at 10:41
  • 3
    \$\begingroup\$ See Can I include problem statements when posting exercise solutions to Code Review?. In short, a link alone is not sufficient (the question must be complete in itself), but you may need to write the requirements in your own words - unless you have specific permission to copy and republish. \$\endgroup\$ Commented Mar 18, 2019 at 10:43
  • \$\begingroup\$ I think online programming challenges are by default public domain? \$\endgroup\$ Commented Mar 18, 2019 at 10:46
  • 3
    \$\begingroup\$ @TobySpeight Although it's unlikely to be deleted by the community, since the community is explicitly not tasked with legal enforcement. That's SE-employees territory, it goes even beyond the moderators. \$\endgroup\$
    – Mast
    Commented Mar 18, 2019 at 12:52

1 Answer 1



import math, os, random, re, sys
from collections import defaultdict as dd, Counter as count

Seriously, don't do this. It may be useful to read PEP8 regarding imports again.

  • Imports should be on separate lines.

  • Why do Counter as count? It impairs readability.

    Especially in larger scripts, every Python dev knows Counter, but count could be a random variable and is easy to be overshadowed.

  • You don't use all of the imported modules; just remove them if you don't need them.

  •    alphabet = "abcdefghijklmnopqrstuvwxyz"

    Here you missed something that is in the standard lib: from string import ascii_lowercase


  • This dd(lambda: 0, ... adds no value

    Counter is already a dictionary with default value 0 just remove that part

  • Magic numbers

    5 is a Magic number, you should define it as a CONSTANT:

      NAME_LENGTH = 5

The rest looks good!

  • 6
    \$\begingroup\$ May as well avoid aliasing defaultdict, too. Who the heck is going to know what dd is if they skip past the imports? \$\endgroup\$
    – jpmc26
    Commented Mar 18, 2019 at 18:28
  • 5
    \$\begingroup\$ Respectfully no, the same advice goes for aliasing defaultdict. In this small example it doesn't matter, and it's easy to read, but when you are working on larger projects this can be a true pain in the *** \$\endgroup\$
    – Ludisposed
    Commented Mar 18, 2019 at 19:03
  • 1
    \$\begingroup\$ @jpmc26 Yeah I thought it meant Disk Destroyer at first. \$\endgroup\$
    – Peilonrayz
    Commented Mar 18, 2019 at 19:51
  • 6
    \$\begingroup\$ @TobiAlafin You need to learn the Principle of Least Astonishment. The biggest thing you should do to make your code readable and maintainable is to avoid doing things that are surprising. Aliasing something that's referenced exactly once is the code is weird. It's surprising. So is abbreviating names from the standard library. Don't do things that will surprise other developers. Do normal things. Great code is so obvious, it makes you think you could have easily thought of it. \$\endgroup\$
    – jpmc26
    Commented Mar 18, 2019 at 20:25
  • 3
    \$\begingroup\$ @jpmc26 That's a solid principle,.. I will use this in future code reviews :) \$\endgroup\$
    – Ludisposed
    Commented Mar 18, 2019 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.