Skip to main content
10 events
when toggle format what by license comment
Jun 2, 2014 at 19:49 comment added RubberDuck Hopefully someone will still come along who knows more about what you're doing. I just saw some things that raised flags and wanted to make sure you got some feedback.
Jun 2, 2014 at 19:49 comment added blaze4218 That is my least favorite part as well. If I were using C# there would be a keyword "lock" that abstracts the try/finally that is necessary for the use of Monitor. Since that doesn't exist in JScript I had to write it all out manually. That's one of the main reasons for coming here...
Jun 2, 2014 at 19:47 comment added RubberDuck I think it's got a smell to it, but I could be way off. I'm unfamiliar with the language and what you're doing. The number of nested code blocks raise a flag for me, but my spidey sense could be a little wonky today.
Jun 2, 2014 at 19:46 comment added RubberDuck I clarified about the right aligned comments. Like I said @blaze4218, others may disagree with me. I think they're hard to read that way.
Jun 2, 2014 at 19:45 history edited RubberDuck CC BY-SA 3.0
added 261 characters in body
Jun 2, 2014 at 19:43 comment added blaze4218 This was useful to reconfirm some of my bad habits. While not quite what I was hoping for- I will upvote it as useful once I unlock that ability.
Jun 2, 2014 at 19:40 comment added blaze4218 The 32 line comment was only for the sake of this code review to implore the focus of the reviewers efforts be on that function as it was the hardest for me to write and I may have been overly verbose. I could actually sum up the function more briefly, but again- that was an aside detailing more than what the function was doing. I am weary of it because it contains the brunt of the locking for my first attempt at multithreading. So does it smell? Not other than what I mentioned about 1 or 2 threads possibly spinning up and doing nothing, I just don't know- that's why I'm here...
Jun 2, 2014 at 19:40 comment added blaze4218 To your point about inconsistent white space Thank you, this is one I work on constantly. It was worse before I reviewed it 15 times in anticipation of your review. I will continue to work on it. The empty else statement is one I use in debugging, I would normally have a console.log there to make sure it is unreachable (it should be unreachable). I should have taken it out. I chose queryMessage to match the syntax of the other sendMessage and consumeMessage. Can you offer a more appropriate naming convention?
Jun 2, 2014 at 19:39 comment added blaze4218 I don't understand your distinction between "end of line" and "right aligned" comments. I used the word that made sense to me, but basically all of my comments are "end of line" comments with spacing on some to make sure they all start at the same col. This seems to me as straight forward as your comment about consistent spacing. I can understand not using it in a project with others, but I find it very hard to read code with comments within the code. I put the comments for each function to be compatible with your viewing preference, inherently rendering the right aligned comments unnecessary.
Jun 2, 2014 at 17:43 history answered RubberDuck CC BY-SA 3.0