I currently have code that looks like this
private string _stringField;
protected string StringField
{
get
{
if (_stringField == null)
_stringField = GetStringField();
return _stringField;
}
}
ReSharper is suggesting I change the property to:
protected string StringField
{
get
{
return _stringField ?? (_stringField = GetStringField());
}
}
This isn't an idiom I've seen before and probably would have to think about the first time I saw it; is this something I should be concerned would confuse other people too?