From you logic I am assuming you have two possible values and you want to switch the current value to the other one?
If so, I must admit that it is not clear immediately this is what you are trying to do. For this reason, I would personally prefer to use an if else statement which would be easier to read/follow:
//switch the value
if(cobBereich.DropDownStyle == ComboBoxStyle.DropDownList)
cobBereich.DropDownStyle = ComboBoxStyle.DropDown;
cobBereich.DropDownStyle = ComboBoxStyle.DropDownList;
Of course, the code you have already is perfectly valid. So I would say go with what you find easier to read.