This question is about your opinions and/or existing conventions.
Let's say I have an object
Basket that store various items in some private property (
Basket._items). Now, I want to have a couple of methods for adding, removing and getting items.
Each method can take either a single item or a list of items as an argument, or with no arguments, in the case of removing and getting, may remove or return all items.
How do you think I should name my methods?
(They don't all have to be the same form; for instance, maybe only the last one should be plural.)